Jump to content

Πώς η HP χύνει το γάλα με την υποστήριξη για Linux των πολυμηχανημάτων της


Recommended Posts

Λοιπόν.... Κύριοι της HP... για διαβάστε ένα μικρό story:

 

Το καλό μου Canon MP630 πολυμηχάνημα 10ετίας μια χαρά με εξυπηρετούσε με τα συμβατά μελάνια του (15 ευρώ έδινα για τα 5 που δέχεται) για τις περιστασιακές έγχρωμες εκτυπώσεις μου. Στα windows 10 δεν υπήρχε καν υποστήριξη. Δεν υπήρχαν drivers και οι παλιοί (win7) δεν προχωρούσαν σε εγκατάσταση. Ευτυχώς στο Linux δούλευαν κάποιοι open source drivers για εκτύπωση (όχι σκανάρισμα). Δυστυχώς την τελευταία περίοδο οι εκτυπώσεις άλλες φορές ολοκληρωνόντουσαν, άλλες φορές έμεναν στη μέση, άλλες φορές κολλούσε ο εκτυπωτής και δεν δεχόταν εντολές από το PC παρά μόνο μετά από restart. Επομένως αποφάσισα γρήγορα γρήγορα για νέο πολυμηχάνημα. 

 

Κατέληξα στον HP 8013 για τους εξής λόγους: α) πρόγραμμα cachback μέχρι τέλη Οκτώβρη β) επέκταση εγγύησης στα 3 χρόνια δωρεάν μέχρι τέλη Οκτώβρη γ) υποστήριξη Linux

 

Λοιπόν τον αγοράζω, μου έρχεται, αποσυσκευάζω, συνδέω. Όλα καλά.

Με το που τον βλέπει το Linux Mint 20 εγκαθιστά στους εκτυπωτές έναν εκτυπωτή ΗP 8010 series. Όμως Δεν τυπώνει, ούτε σκανάρει, επομένως πάμε να περάσουμε τους hplip drivers.

 

Σημειώνω ότι σε αυτό το σημείο για να αποκλείωσω hw πρόβλημα, μπαίνω windows 10, βλέπουν ακριβώς το ίδιο με το linux, αλλά χωρίς λειτουργικότητα, οπότε εγκαθιστώ ΗP λογισμικό και ο εκτυπωτής παίζει.

 

Στο Linux Mint υπάρχει έτοιμο (αν και όχι τελευταία τελευταία έκδοση) στο επίσημο αποθετήριο. Το εγκαθιστώ, το τρέχω, αλλά υπήρχε μια περίεργη συμπεριφορά. Από το HP device manager ο εκτυπωτής δεν επικοινωνούσε και φαινόταν μονίμως busy, ενώ από οποιαδήποτε εφαρμογή μπορούσα να τυπώσω κανονικά. Το σκάνερ δεν λειτουργούσε.

 

"Έλεος" μονολογώ. και κατεβάζω απευθείας από HP το τελευταίο hplip. Εγκαθίσταται από κονσόλα και στο τέλος πετάει ένα σωρό warnings για missing dependancies που καρφωτά με sudo apt-get install δεν μπορούσα να εγκαταστήσω. Επομένως έτσι εξηγείται και το ότι δεν λειτουργούσε η έκδοση των αποθετηρίων διότι δεν πετούσε error το installation sript παρά μόνο κάποια warnings που όταν εγκατέστησα από GUI δεν φαινόντουσαν.

 

Μετά από αρκετό ψάξιμο όπου ένα σωρό γιωτάδες έδιναν συμβουλές να πήξεις στην κονσόλα και παρατηρώντας προσεκτικά τα dependancies διαπίστωσα ότι αυτό που αρκούσε ήταν να περάσεις από τον software manager τα build-essentials οπότε το installation script από την HP έτρεχε κανονικά και το λογισμικό της HP λειτουργούσε εν τέλει άψογα. Θα μπορούσα να ψάχνομαι για ώρες καθώς πουθενά δεν υπήρχε σχετική προειδοποίηση ούτε και κάποια οδηγία στο επίσημο site του hplip.

 

Γιατί καλή μου HP. Γιατί δεν το γράφεις ευκρινώς? Γιατί το script σου ενώ πετάει τόσα warnings, δεν μπορεί να ζητήσει ή να εγκαταστήσει και μόνο του τα build-essentials? Πόσο γιωτάδες είστε και πόσο κακό κάνετε στο Linux με αυτό τον τρόπο, μολονότι αποφάσισα να σας τιμήσω ακριβώς για αυτή την υποστήριξη που ούτε η epson, ούτε η cannon ούτε και κάποιος άλλον κατασκευαστής inkjet πολυμηχανημάτων διαθέτει (το hplip υποστηρίζει σχεδόν το σύνολο των εκτυπωτών και scanner της HP, με εκδόσεις για όλες τις γνωστές διανομές). Πραγματικά τόσο κόπο έκαναν για όλη αυτή την υποστήριξη, γιατί να χύνουν το γάλα διά αυτού του τρόπου? Και αν γκουγκλάρεις ένα σωρό περιγραφές του προβλήματος υπάρχουν, χωρίς βέβαια κάπου εγώ προσωπικά να βρήκα με σαφήνεια γραμμένο ότι απαιτούνται τα build-essentials για να γίνει σωστά η εγκατάσταση, η οποία ολοκληρώνεται μερικώς και μη λειτουργικό πολυμηχάνημα (τουλάχιστον στην περίπτωσή μου - για άλλα μοντέλα δεν ξέρω).

  • Like 9
Link to post
Share on other sites

Πειρατεία νήματος. Μιας και είχες κάνον, προσπάθησα σε μιντ να βάλω τον οδηγό της κάνον κι έφαγα όλα τα άκυρα που περιγράφεις πιο πάνω για τον ΗΡ σου. Έχεις βρει τίποτα που να δουλεύει; Θέλω να παίζω με φωτογραφικές εκτυπώσεις οπότε χρειάζομαι λίγο έλεγχο στην εκτύπωση. Τελευταίο μιντ

Link to post
Share on other sites
Just now, schumifer said:

Πειρατεία νήματος. Μιας και είχες κάνον, προσπάθησα σε μιντ να βάλω τον οδηγό της κάνον κι έφαγα όλα τα άκυρα που περιγράφεις πιο πάνω για τον ΗΡ σου. Έχεις βρει τίποτα που να δουλεύει; Θέλω να παίζω με φωτογραφικές εκτυπώσεις οπότε χρειάζομαι λίγο έλεγχο στην εκτύπωση. Τελευταίο μιντ

 

Για τον mp630 που είχα, χωρίς ποτέ η canon να δηλώνει υποστήριξη για Linux, ο εκτυπωτής έπαιζε μέχρι το mint 19 out of the box, plug and play κατάσταση. Από το mint 20 και μετά άρχισαν περίεργες συμπεριφορές, όπως πότε να τυπώνει κανονικά, άλλες φορές να μένει στη μέση η εκτύπωση και να κολλάει και άλλες φορές να μην δέχεται καν την εντολή εκτύπωσης (ο εκτυπωτής) και να πρέπει να του κάνω restart (του εκτυπωτή). Δεν ξέρω αν οφείλεται στη 10ετία ζωής του ή στο νέο mint, καθώς στα win δεν μπορούσα να τον δοκιμάσω εφόσον δεν έπαιζε με την καμία (η canon είχε τερματίσει την υποστήριξη από τα win7).

 

Οπότε δεν έχω ψαχτεί καθόλου για canon μια που στη δικιά μου περίπτωση ήταν αυτόματη φάση.

 

Ποιο μοντέλο έχεις? Δίνει linux drivers η canon ή όχι? Τι γράφει στη σελίδα προϊόντος?

 

 

Edited by gdp77
Link to post
Share on other sites

Όπως και με τις Corsair μνήμες και το πρόβλημα που είχες με αυτές, έτσι και με τον εκτυπωτή είσαι ο ορισμός του ρητού, ο επιμένων νικά.

 

  • Like 3
Link to post
Share on other sites

O Epson L655 παίζει μια χαρά πάντως στο Mint. Έχουν και κάποια πακέτα με drivers στη σελίδα τους, όχι τρελά εύχρηστα πάντως.

Link to post
Share on other sites
Just now, trendy said:

O Epson L655 παίζει μια χαρά πάντως στο Mint. Έχουν και κάποια πακέτα με drivers στη σελίδα τους, όχι τρελά εύχρηστα πάντως.

 

Είμαστε παιδιά κατώτερου θεού οι χρήστες Linux και οι εταιρείες μας έχουν γραμμένους στα @@@@@@@ τους. Basic drivers και πολύ μας είναι... 

 

Πάντως το hplip έχει σχεδόν την ίδια λειτουργικότητα με τους windows drivers. Μακάρι να συνεχίσουν να το αναπτύσσουν. Και για πρώτη φορά βλέπω ότι υπάρχει και υποστήριξη fax, αλλά το δικό μου πολυμηχάνημα δεν έχει fax για να το δοκιμάσω... Είδα σοβαρή προσπάθεια και για αυτό αποφάσισα να στηρίξω  HP με την αγορά μου, ενώ ποτέ στο παρελθόν δεν έχω αγοράσει εκτυπωτή ή κάτι άλλο από αυτούς.

Edited by gdp77
Link to post
Share on other sites

Κι εγώ μόνο HP έπαιρνα μέχρι που το ξεφτύλισαν με τις τιμές των μελανιών. Ο εκτυπωτής έφτασε να είναι πιο φτηνός από τα αυθεντικά μελάνια και οι λύσεις γεμίσματος δε δούλευαν πάντα.

Link to post
Share on other sites
9 minutes ago, trendy said:

Κι εγώ μόνο HP έπαιρνα μέχρι που το ξεφτύλισαν με τις τιμές των μελανιών. Ο εκτυπωτής έφτασε να είναι πιο φτηνός από τα αυθεντικά μελάνια και οι λύσεις γεμίσματος δε δούλευαν πάντα.

 

Αυτό ισχύει με όλους νομίζω. Απλά περιμένεις να παλιώσει ο εκτυπωτής για να βγούνε "συμβατά" της προκοπής και να κάνεις τη δουλειά σου με αυτά, αν είσαι τυχερός και δεν σου χαλάσει ο εκτυπωτής.

  • Like 1
Link to post
Share on other sites

Αν και παλιός επσονάς, έχω βρει την υγεία μου με τον κάνον. Αγοράζετε παλιότερο μοντέλο κάνον, που να έχει ήδη τσιπάκια εμπορίου. Παίρνετε κι ένα ciss σύστημα και έχετε καλή συνταγή για ελάχιστο κόστος με άπειρες εκτυπώσεις. Και αν κάνει κόλπα η κεφαλή, βγαίνει σε δευτερόλεπτα, για manual καθαρισμό.

 

Στην προηγούμενη ερώτησή μου. Ο MG6150 αναγνωρίζεται στο μιντ, το σκάνερ του όχι. Ήθελα να βάλω όμως τον οδηγό της κάνον, μπας και οι εκτυπώσεις μου από λίνουξ πλησίαζαν σε αποτύπωση χρωμάτων αυτές από παραθύρια.

https://tutorialforlinux.com/2019/10/07/how-to-install-canon-pixma-driver-on-linux-mint-19-easy-guide/2/

Αυτός είναι ένας από τους οδηγούς που προσπάθησα να ακολουθήσω. Προφανώς δούλευε καλά σε προηγούμενες εκδόσεις μιντ. Εμένα όλο προβλήματα με τα dependencies μου έβγαζε, και σε φάση  ''α και γαμήλιο΄΄ προσπάθησα να κάνω κάτι σούντο φορς ινσταλ τα dependencies αλλά και πάλι δεν κατάφερα τίποτα.

Αν έχεις το τελευταίο μιντ κάνε μία προσπάθεια αν δε σου κάνει κόπο και αν δε σου βγάλει dependency error, θα το ξαναδοκιμάσω. Προς το παρόν, στο πισί που έχω το μιντ μπαίνω μία φορά την εβδομάδα και επειδή εκτυπώνω, μπαίνω παραθύρια

  • Like 1
Link to post
Share on other sites
πριν 38 λεπτά, το μέλος schumifer έγραψε:

dependencies

 

H θα τα περναγα χεράτα ή θα έβαζα τα repo της προηγούμενης έκδοσης, αφού σε αυτήν έπαιζε.

  • Like 1
Link to post
Share on other sites
πριν 7 ώρες, το μέλος gdp77 έγραψε:

 

Αυτό ισχύει με όλους νομίζω. Απλά περιμένεις να παλιώσει ο εκτυπωτής για να βγούνε "συμβατά" της προκοπής και να κάνεις τη δουλειά σου με αυτά, αν είσαι τυχερός και δεν σου χαλάσει ο εκτυπωτής.

Ναι, απλώς ο L655 έχει μελανοδοχεία που μετά από περίπου 2 χρόνια είναι στο 1/4.

Link to post
Share on other sites
2 hours ago, Rusty_Cookie said:

 

H θα τα περναγα χεράτα ή θα έβαζα τα repo της προηγούμενης έκδοσης, αφού σε αυτήν έπαιζε.

Θα ξανακάνω τη διαδικασία για να ανεβάσω τα μηνύματα σφάλματος, αλλά αυτό προσπάθησα να κάνω. Έπαιρνα ένα ένα τα dependencies που έλειπαν και προσπαθούσα να τα βάλω, είτε από γραφικό περιβάλλον ή  με dpkg. Πάει κάπου ένας μήνας, θα το ξανακάνω μέσα στο σκ και θα ανεβάσω. Θενξξξξξξξ

  • Like 1
Link to post
Share on other sites
πριν 10 ώρες, το μέλος Rusty_Cookie έγραψε:

θα έβαζα τα repo της προηγούμενης έκδοσης, αφού σε αυτήν έπαιζε.

Νομιζω αυτο θα παιξει πιο καλα ενα backport repo βαλε

  • Like 1
Link to post
Share on other sites

Λοιπόν update:

 

Τελικά στο desktop αρνείται να εγκατασταθεί σωστά το hplip 3.20.9 (τελευταίο).

Στο laptop το πέρασα κανονικά με τη διαδικασία που προανέφερα (εγκατάσταση πρώτα build-essentials). 

 

Ο λόγος μετά από διερεύνηση είναι ότι οι βιλιοθήκες python qt4 έχουν γίνει deprecated στο Linux Mint 20 (αλλά και στο ubuntu 20.04 και μεταγεννέστερο).

 

Γιατί όμως πέρασε στο laptop? Ο λόγος ήταν ότι ήμουν 1-2 updates πιο πίσω στο laptop (λόγω περιοδικής και όχι τακτικής χρήσης) οπότε το hplip πέρασε. Στο desktop που είμαι fully updated το hplip δεν εγκαθίσταται σωστά, υπάρχουν αρκετά missing dependencies που δεν μπορείς να περάσεις ούτε "χεράτα". Έχω αναφέρει (μαζί με άλλους) το πρόβλημα στο hplip launchpad.

 

Αυτή τη στιγμή στο desktop το hplip τρέχει αλλά βλέπει τον printer μονίμως "busy". Το web interface δουλεύει και μπορώ να σκανάρω μόνο μέσω wifi. Αντίθετα η εκτύπωση μπορεί να εκτελεστεί μέσω USB από την οποιαδήποτε εφαρμογή, αλλά όχι μέσα από το hplip (το λογισμικό της hp). Σκανάρω και εκτυπώνω δηλαδή αλλά με διαφορετικό τρόπο κάθε φορά... Ένας απλός χρήστης δεν νομίζω ότι θα μπορούσε... Γενικά, κύριοι της HP, κάντε δουλίτσα, περάστε το hplip σε qt5 ή κυκλοφορήστε το hplip σε appimage, snap, flatpak whatever. 

 

ΥΓ απόδειξη όλων των παραπάνω είναι ότι αν μπουτάρω με linux mint live (μαμίσιο mint δηλαδή) το hplip εγκαθίσταται κανονικά. Να δούμε τι θα γίνει αν κάνω update στο laptop. Θα συνεχίσει να παίζει σωστά ή θα μας χαιρετίσει και εκεί; 

 

Κρίμα γιατί αγόρασα αυτό το πολυμηχάνημα με την προσδοκία της 100% και απροβλημάτιστης λειτουργίας στο Linux, κάτι που προς το παρόν δεν έχω.... 

Edited by gdp77
  • Like 2
Link to post
Share on other sites
14 hours ago, steve_m said:

παρτε αδερφο που εχει και official support   ρε παιδια

 

"official" support έχει τουλάχιστον και η HP. Τώρα μπήκα να κοιτάξω στην brother, δίνει rpm και deb πακέτο, πράγμα που μάλλον είναι καλό για τα ποσοστά επιτυχίας εγκατάστασης, ανάλογα τη διανομή.

 

Το θέμα είναι ποιο functionality δίνει με αυτά τα πακέτα. Το fax λειτουργεί; Το σκάνερ? Δίνονται όλες οι επιλογές εκτύπωσης;

 

Το hplip βλέπω (βάσει UI) ότι δίνει τα πάντα όλα όπως και στα windows. Το πρόβλημα είναι ότι η ΗP αργοπόρησε και την πρόλαβαν οι εξελίξεις με το deprecation του qt4 σε δημοφιλείς διανομές. 

 

@Rusty_Cookie

Μια που διαφαίνεται ότι όλοι προσπαθούν να δώσουν linux support, τι είναι αυτό που εμποδίζει κατά τη γνώμη σου την απροβλημάτιστη υποστήριξη όπως και στα windows? Είναι το Linux με τις συνεχόμενες αναβαθμίσεις κινούμενη άμμος? Δεν λέω για την κάθε διανομή, αλλά τουλάχιστον τις δημοφιλείς (με πακέτα deb και rpm) θα έπρεπε να τις υποστηρίζουν απρόσκοπτα.. Ούτε αυτό όμως...  Μήπως δεν έχει προτυποποιηθεί το CUPS? Δεν ξέρω.... Δεν είμαστε αρκετοί χρήστες και το feedback για διόρθωση bugs και προβλημάτων είναι ανεπαρκές?

  • Like 1
Link to post
Share on other sites

Σχετικά με την υποστήριξη, τι να φταίει, το προφανές: το ότι σε SOHO μηχανήματα το μερίδιο αγοράς είναι μηδενικό. Γιατί να ασχοληθούν? 

 

Και εδώ σε σένα δε φταίει ακριβώς η ΗΡ.

Τρέχεις testing, μη το ξεχνάς. Λογικό να έχεις κάποια προβλήματα. 

  • Like 1
Link to post
Share on other sites
14 minutes ago, Rusty_Cookie said:

Σχετικά με την υποστήριξη, τι να φταίει, το προφανές: το ότι σε SOHO μηχανήματα το μερίδιο αγοράς είναι μηδενικό. Γιατί να ασχοληθούν? 

 

Και εδώ σε σένα δε φταίει ακριβώς η ΗΡ.

Τρέχεις testing, μη το ξεχνάς. Λογικό να έχεις κάποια προβλήματα. 

 

Παραξενεύομαι διότι δηλώνουν επισήμως υποστήριξη Linux, σε SOHO μηχανήματα, παρά το "μηδενικό" μερίδιο αγοράς. Εφόσον λοιπόν το μερίδιο αγοράς είναι το σημαντικότερο κίνητρο (όπως γράφεις και συμφωνώ), τότε γιατί δεν φροντίζουν στις δημοφιλείς διανομές να έχουν σωστή υποστήριξη; Το hplip για τους λόγους που προανέφερα δεν παίζει σωστά σε ubuntu 20.04 και μεταγενέστερο και mint 20. Μη που πεις ότι δεν είναι δημοφιλείς διανομές; Πού παίζει σωστά; Ενδεχομένως σε "stable" διανομές; Αλλά αυτές έχουν αρκετά μικρότερο μερίδιο χρήσης, νομίζω.

 

ΥΓ Μια χαρά φταίει η HP διότι δηλώνει στο τελευταίο hplip "mint 20 support", που δεν ισχύει 

Edited by gdp77
Link to post
Share on other sites

Δεν έχει σχέση τι είναι δημοφιλές και τι όχι. Δεν είναι διαφορετικό το development που θέλει το κάθε derivative μιας διανομής η και κάθε διαφορετική διανομή. Το πακετάρισμα αλλάζει κυρίως.

Με το μερίδιο αγοράς που έχει συνολικά το λινουξ στο SOHO απλά πρέπει να αποδεχτείς πως για κάποιες εταιρείες θα είσαι 2nd class citizen. 

 

Για να μην μένεις έκπληκτος όταν κάτι δεν παίζει ξαφνικά πρέπει να κατασταλάξεις στο τι σκοπό θες να εξυπηρετεί το εκάστοτε μηχάνημα που στήνεις.

Θέλεις συμβατότητα στο μέγιστο χωρίς να σκαλίζεις τα εσωψυχα του package manager και των conf files? = Παλιά πακέτα με LTS kernel η Windows. 

Παλιά πακέτα οργανωμένα σωστά έχει το stable Debian και το CentOS.

Αν θες testing πακέτα οργανωμένα σωστά και πρόσφατο kernel πας σε fedora η testing Debian. Αν θες PPA και snap μαζί με τα πρόσφατα πακέτα σου πας Ubuntu με μειονεκτήμα τις συχνότερες ασυμβατότητες.

Θες bleeding edge? Debian Sid η Arch αλλά πρέπει να είσαι σε εγρήγορση όταν κάνεις updates.

Όλα αυτά ανεξάρτητα από το de σου. Μπορείς να έχεις centos με mint. Η Debian με budgie, arch με unity η whatever.

Ακόμα και στα Windows αν είσαι σε canary channel θα είναι σαν να έχεις testing διανομή και θα σπάνε πράγματα κάποιες φορές.

 

Το δε hplip το χω και γω εγκατεστημένο για Samsung μηχάνημα στο πατρικό μου σε set and forget μηχανάκι με cent και gnome3. Είναι updated, είναι secure το σύστημα και ο driver έπαιξε κομπλέ. Θέλει ο πατέρας μου ταδεlib v1.0.9 αντί 1.0.0.2 εντός δύο βδομάδων απ' όταν βγεί όπως στο Ubuntu? Δε νομίζω. Εκτυπώνει με το πολυμηχανημα χωρίς πρόβλημα? Ναι. Είναι δημοφιλές το distro του? Who cares. Computers are appliances for most people.

 

Ps.:

Η ΗΡ σου τον δίνει τον driver αλλα πως μπορούν να ξέρουν πως είναι στημένο το σύστημά σου και αν κάνει meet τα dependencies? Δεν υπάρχει κάποιο ελάχιστο στάνταρ βιβλιοθηκών.

Αν θέλεις κάνε compile απ' την αρχή η βάλε  repack από άλλον. Όπως και έχουν γίνει repacks για το hplip με δικό τους ρέπο κλπ για dpkg based διανομές.

Link to post
Share on other sites
28 minutes ago, Rusty_Cookie said:

Ps.:

Η ΗΡ σου τον δίνει τον driver αλλα πως μπορούν να ξέρουν πως είναι στημένο το σύστημά σου και αν κάνει meet τα dependencies? Δεν υπάρχει κάποιο ελάχιστο στάνταρ βιβλιοθηκών.

Αν θέλεις κάνε compile απ' την αρχή η βάλε  repack από άλλον. Όπως και έχουν γίνει repacks για το hplip με δικό τους ρέπο κλπ για dpkg based διανομές.

 

Γράφουν ότι υποστηρίζουν mint 20. Σου λέω λοιπόν ότι έκανα εγκατάσταση hplip από μαμά mint (live μάλιστα, πιο μαμά δεν γίνεται) και δεν λειτουργεί σωστά με τον εκτυπωτή μου. Οι "drivers" που δίνουν είναι ουσιαστικά script που κάνει compile από source το οποίο ΔΕΝ εκτελείται διότι του λείπουν dependencies που ΔΕΝ υπάρχουν στο mint 20 που ΛΕΝΕ ότι υποστηρίζουν. Ε ναι, άμα γίνω hacker θα το καταφέρω να παίξει αλλά δεν είναι αυτό το νόημα. Εμένα το παράπονό μου είναι ότι ΕΦΟΣΟΝ γράφεις ότι υποστηρίζεις mint 20 (άρα και Ubuntu 20,04 LTS) φρόντισε να το κάνεις, Αλλιώς μην το γράφεις καθόλου και γράψε "debian stable" να τελειώνουμε.

Edited by gdp77
  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.