Jump to content



Mikrotik Dyndns Scipt


Vatos_locos

Recommended Posts

πείτε μου κάποιος τι κάνω λάθος και δεν παίζει το άτιμο

δεν κάνει update

# Define User Variables
:global ddnsuser "[COLOR="DarkSlateBlue"]Όνομα Χρήστη[/COLOR]"
:global ddnspass "[COLOR="DarkSlateBlue"]Κωδικό[/COLOR]"
:global ddnshost "[COLOR="DarkSlateBlue"]χχχ.dyndns.org[/COLOR]"

# Define Global Variables
:global ddnsip
:global ddnslastip
:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }

:global ddnsinterface
:global ddnssystem ("mt-" . [/system package get system version] )

# Define Local Variables
:local int

# Loop thru interfaces and look for ones containing
# default gateways without routing-marks
:foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
:if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
:global ddnsinterface [/ip route get $int interface]
}
}

# Grab the current IP address on that interface.
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

# Did we get an IP address to compare?
:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("DynDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
:if ($ddnsip != $ddnslastip) do={
:log info "DynDNS: Sending UPDATE!"
:local str "/nic/update?hostname=$ddnshost&myip=$ddnsip&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
:delay 1
:local str [/file find name="DynDNS.$ddnshost"];
/file remove $str
:global ddnslastip $ddnsip
}
}

Link to comment
Share on other sites

Από όσο ξέρω το mikrotik δε παίζει με dyndns.

Δοκίμασε το changeip.net

Υπάρχει αντίστοιχο script στο wiki του mikrotik.

Link to comment
Share on other sites

ναι το έχω δει οτι δεν παίζει και καλά αλλά αυτό το script το δίνουν στο wiki του routerOS για dyndns

και ενώ στο log λέει Sending DNS Update παίρνω ένα σακί @@ πίσω

Link to comment
Share on other sites

τι σκατά λένε οτι παίζει με dyndns στο wiki της mikrotik δεν καταλαβαίνω...

με changeip.net παίζει μια χαρά

thanks NickL θα το αφήσω έτσι αφού παίζει :)

Link to comment
Share on other sites

Προσοχή μην τα βαλλεις να παίζουν κ τα 2 ταυτοχρονα γιατί χρησιμοποιουν τα ίδια variables.

οχι ρα είπαμε δεν είμαι τόσο :p

μπήκε με change ip και τέλος

τώρα βέβαια βρήκα άλλο μπελά

θέλουν να κάνουμε export το User configuration

( ότι είναι made by user και όχι από το setup )

και το μόνο που έχω καταφέρει είναι να κάνω export όλο το config :brutal003:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.