Jump to content

Raid 0 + Chkdsk. ΤΟ ΧΑΛΑΣΑ!!!


Recommended Posts

Καλησπέρα σας και χρόνια πολλά.

Έχω δύο 300 maxtor sata1, σε Raid 0, σε κάθε partition άλλο λειτουργικό.

Μετά από κάποιο πρόβλημα στα ΧP σήμερα, έκανα από τα vista Chkdsk/f.

Όπως καταλαβαίνετε, το raid 0 δεν ξανάπαιξε, έχω intel ich9r controller ο οποίος έβγαζε error στον ένα δίσκο.

Διάβασα κάποια threads εδώ πριν γράψω και έτσι αποφάσισα να σβήσω το raid0 Και να το ξαναφτιάξω χωρίς αποτέλεσμα όμως.

Δοκίμασα μετά το RaidReconstructor από άλλο δίσκο non raid, μου λέει κάτι ιστορίες για 29 ώρες κλπ και δε μου φαίνεται τίποτα το ιδιαίτερο. To σταμάτησα.

Τι μπορώ να κάνω για να το επαναφέρω; Τώρα αν κανω boot μου λέει ότι έχει γίνει format στους δίσκους. Δεν είναι τα πολύ σημαντικά αρχεία για μένα όμως θα ήθελα να τα ξαναβρω.

Ευχαριστώ πολύ

Lefteris

Link to comment
Share on other sites

Ξαναδημιούργησε το raid με τις αρχικές ρυθμίσεις. Όπως ήταν στην αρχή. Μετά χρησιμοποίησε αυτό: http://www.r-studio.com/

Κάνε full scan και αν σου τα βρει τα αρχεία τότε πάρε την full απλή έκδοση και σώσε τα αρχεία σου.

Υ.Γ.: Μερικές φορές μου έκανε νερά το πρόγραμμα και δεν έβγαζε κανένα χρήσιμο αρχείο στο τέλος του scan. Η λύση: Σταματάς το scan πριν τελειώσει. Έτσι είσαι σίγουρος ότι βρήκε τα αρχεία διότι στην αρχή βρίσκει τα εύκολα (τα πιο πρόσφατα) και μετά τα υπόλοιπα που είχαν σβηστεί/φορμαριστεί...

Καλή τύχη.:)

Link to comment
Share on other sites

Βασικά αν το βάλω σε RAID mode από το bios δε μπορεί να μου bootarei με τον βοηθητικό δίσκο sata, γιατί είναι τόσο έξυπνο το bios που θέλει να τα βλέπει όλα sata ή όλα raid... Τι άλλο να δοκιμάσω;

Ο controller που έχω δεν διαθέτει repair..

Link to comment
Share on other sites

Θεωρω πιθανότατα οτι εχει γινει λαθος χειρισμός απο την αρχη.

το chkdisk ειναι κακιστη λυση για συστηματα με raid 0, ειναι σχειδασμενο να παιζει με μονους δισκους, και δε βλεπει το array. 99% των περιπτωσεων καταστρεφει τα δεδομενα.

Το error για το raid 0 στο εβγαζε κατα το boot?

Εαν ναι πιθανοτατα δεν εχασε τον ενα δισκο.

Η πρωτη σου κινηση ηταν να ξαναφτιαξεις το array ΧΩΡΙΣ να του επιτρεψεις να διαγραψει τα δεδομενα του array. link

Απο τη στιγμη που εκανες rebuild το array απο το raid bios φανταζομαι εξαφανιστηκε το error σωστα? Αλλά πλεον δε μπορουσες να bootαρεις.

Εαν ειναι ετσι τσαμπα παιδευεσε απλα διότι εσβησες τα περιεχομενα του array.

Το raid 0 δυσκολα επαναφερεται, στη καλυτερη περιπτωση να παρεις καποια αρχεια απο αυτο και όχι παλι ενα πληρως λειτουργικο boot raid 0 array.

Link to comment
Share on other sites

Δυστυχώς θα συμφωνήσω με τον φίλο panoc. Το RAID-0 θέλει προσοχή κατά την επιδιόρθωση από σφάλματα ...

Αν στραβώσει κάτι με το RAID θέλει ιδιαίτερη προσοχή γιατί 9.5/10 περιπτώσεις χάνεις τα πάντα από δεδομένα. Προγράμματα που δεν είναι φτιαγμένα για RAID τις περισσότερες φορές το βλέπουν ως 2 μεμονωμένους δίσκους και τα κάνουν μαντάρα αφού αντιλαμβάνονται τα stripes από τα αρχεία ως λάθη.

Το r-studio με όποιο τρόπο δοκίμασα να το δουλέψω σε αντίστοιχο πρόβλημα που είχα πριν από 1-2 χρόνια δεν έκανε τίποτα. Έβλεπε αρχεία σε μεμονωμένους δίσκους αντί του RAID κομματιασμένα (λόγω stripes 64K) που τα νόμιζε ως corrupted data. Δεν ξέρω αν οι πρόσφατες εκδόσεις είναι πιο αποτελεσματικές ...

Link to comment
Share on other sites

Έχετε απόλυτο δίκιο παιδιά, προσπάθησα να διορθώσω αρχικά το λειτουργικό αλλά έκανα λάθος. Λίγο μετά έμαθα ότι το chkdsk είναι απαγορευτικό για raid0. Τώρα το μόνο που κάνω είναι δύο μεμονομένοι δίσκοι και magic recovery pro μήπως πιάσω κάποιο αρχείο, που δεν το νομίζω... Ευτυχώς που δεν είχα σημαντικά αρχεία. Ευχαριστώ πολύ πάντως, κάτι έμαθα και σήμερα

Link to comment
Share on other sites

Το r-studio με όποιο τρόπο δοκίμασα να το δουλέψω σε αντίστοιχο πρόβλημα που είχα πριν από 1-2 χρόνια δεν έκανε τίποτα. Έβλεπε αρχεία σε μεμονωμένους δίσκους αντί του RAID κομματιασμένα (λόγω stripes 64K) που τα νόμιζε ως corrupted data. Δεν ξέρω αν οι πρόσφατες εκδόσεις είναι πιο αποτελεσματικές ...

Ειλικρινά δεν έχω ιδέα! Το έχω δοκιμάσει μόνο σε μεμονομένους δίσκους/partitions κι όχι raid. Μάλλον θα 'ναι όπως τα λες...

Κατάρα στο raid-0 διότι κι εγώ την είχα πατήσει:(

Link to comment
Share on other sites

Βασικά αν το βάλω σε RAID mode από το bios δε μπορεί να μου bootarei με τον βοηθητικό δίσκο sata, γιατί είναι τόσο έξυπνο το bios που θέλει να τα βλέπει όλα sata ή όλα raid... Τι άλλο να δοκιμάσω;

Ο controller που έχω δεν διαθέτει repair..

Ποια μητρική έχεις ? γιατί σε μένα ναι μεν δηλώνεις στο bios οτι είναι raid αλλά βλέπει σαν raid δίσκους μόνο αυτούς που του δηλώνω να δει στο bios του raid controller και τους υπόλοιπους τους βλέπει κανονικά (3 raid 0 + 1 normal)

Link to comment
Share on other sites

Ποια μητρική έχεις ? γιατί σε μένα ναι μεν δηλώνεις στο bios οτι είναι raid αλλά βλέπει σαν raid δίσκους μόνο αυτούς που του δηλώνω να δει στο bios του raid controller και τους υπόλοιπους τους βλέπει κανονικά (3 raid 0 + 1 normal)

Έχω την P5K E Wifi, με το P35 της intel πάνω. Ναι, το σωστό είναι να το βλέπει όπως η δικιά σου. Είναι και αυτή υπέρ της μαζοποίησης (όπως το facebook :)

Link to comment
Share on other sites

Και σαν να μην έφταναν όλα αυτά, έκανα delete το array από τον raid contoller αλλά ο δίσκος φαίνεται να έχει πλέον σοβαρό πρόβλημα...

Δεν μπορούσα να τον φορμάρω, από το partition magic 8, τον είδε σαν RAW, το διόρθωσε, αλλά, δεν κάνει με τίποτα πλέον full format. Από πλευράς hardware, φαίνεται εντάξει στο pc check. Αλλά πιστεύω ότι για να μην κάνει format, κάτι χάλασε.

Τι λέτε; Να τον γυρίσω για rma? και τι να πω;

Link to comment
Share on other sites

Τι λέτε; Να τον γυρίσω για rma? και τι να πω;

Τι τι να πεις? Ο δισκος χαλασε. Δεν φταις εσυ που χαλασε.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.