Jump to content



Automount network storage on boot


MasterCommander

Recommended Posts

Καλησπέρα, linux noob εδώ.

Τα πράγματα έχουν ως εξής : σε ένα raspberry pi 3, του έχω περάσει Rasbian lite. Θέλω να κάνει mount ένα usb stick που βρίσκεται πάνω στο router, αύτοματα στο boot.

Έχω κάνει edit το fstab, αλλά ενώ το mount γίνεται κανονικά, δημιουργεί αλλού πρόβλημα φαίνεται κατά τη διάρκεια του boot, και ο governor δεν γυρνάει από powersave σε ondemand, με αποτέλεσμα το pi να λειτουργεί μόνιμα στα 600 MHz.

 

Παραθέτω το fstab:

proc            /proc           proc    defaults          0       0
/dev/mmcblk0p1  /boot           vfat    defaults          0       2
/dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
//192.168.1.5/volume1  /mnt/volume1  cifs  password=routerpassword,iocharset=utf8,sec=ntlm  0  0

Έχω κάνει κάπου λάθος? Όποτε επαναφέρω το fstab στο default του ο governor αλλάζει κανονικά.

Edited by MasterCommander
Link to comment
Share on other sites

Αν το κάνεις mount στο τέλος, αφού έχει ολοκληρωθεί το boot, σου αλλάζει τον governor; Δηλαδή βάλε σε σχόλια τη γραμμή στο fstab και όταν φορτώσει τρέξε την mount για το cifs.

 

Ένα workaround που σκέφτομαι είναι να βάλεις στο /etc/rc.local να αλλάζει τον governor αφού το έχει κάνει mount από το fstab.

 

Συνήθως τέτοια προβλήματα εμφανίζονται διότι το fstab καλείται πριν σηκωθεί το δίκτυο, άρα αποτυγχάνουν τα δικτυακά partitions.

Στο δικό μου έχω την παρακάτω γραμμή:

nfs-rpi.μπλα-μπλα.gr:/home/μπλα      /mnt/nfs        nfs     rw,hard,intr,noauto,x-systemd.automount 0       0

 

  • Like 2
Link to comment
Share on other sites

8 minutes ago, trendy said:

Αν το κάνεις mount στο τέλος, αφού έχει ολοκληρωθεί το boot, σου αλλάζει τον governor; Δηλαδή βάλε σε σχόλια τη γραμμή στο fstab και όταν φορτώσει τρέξε την mount για το cifs.

Όταν κάνω το mount εκ των υστέρων δεν μου αλλάζει τον governor.

10 minutes ago, trendy said:

Ένα workaround που σκέφτομαι είναι να βάλεις στο /etc/rc.local να αλλάζει τον governor αφού το έχει κάνει mount από το fstab.

Σωστά, προσθέτοντας 

sudo echo "ondemand" | sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

γυρνάει σε ondemand.

 

Απλά έλεγα μήπως είχα κάποιο λάθος στη σύνταξη ή αν υπήρχε κάποιο option που να καθηστερεί το mount στο boot μέχρι να δει δίκτυο.

 

Η άλλη λύση που δοκίμασα και δουλεύει είναι να βάλω την εντολή για mount στο rc.local και να αφαιρέσω τελείως τη γραμμή από το fstab.

Δεν ξέρω αν θα δημιουργεί κάπου αλλού πρόβλημα..

Link to comment
Share on other sites

45 minutes ago, MasterCommander said:

Σωστά, προσθέτοντας 


sudo echo "ondemand" | sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

γυρνάει σε ondemand.

Δεν είναι απαραίτητο το sudo στο rc.local, γιατί τρέχει ως root.

Επιπλέον ένα απλό

echo "performance" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Κάνει την ίδια δουλειά ;)

 

51 minutes ago, MasterCommander said:

Απλά έλεγα μήπως είχα κάποιο λάθος στη σύνταξη ή αν υπήρχε κάποιο option που να καθηστερεί το mount στο boot μέχρι να δει δίκτυο.

 

Η άλλη λύση που δοκίμασα και δουλεύει είναι να βάλω την εντολή για mount στο rc.local και να αφαιρέσω τελείως τη γραμμή από το fstab.

Δεν ξέρω αν θα δημιουργεί κάπου αλλού πρόβλημα..

Έχω το noauto για να μην το βάζει αυτόματα. Μπορώ να το σηκώνω με "mount -a" ή με script.

Επίσης υπάρχει το

_netdev

option, αλλά δεν είμαι σίγουρος ότι δουλεύει σωστά πλέον.

Καλό είναι να υπάρχει στο fstab πάντως, ώστε να μπορείς να το διαχειρίζεσαι πιο εύκολα. Αλλιώς δε νομίζω να δεις διαφορά.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.