Jump to content

suse 10.1-windows xp network


Recommended Posts

γεια σας! και παλι...

αφου καταφερα να συνδεσω 3 υπολογιστες Windows και να βλεπουν ολοι ολους και να εχουν ολοι ιντερνετ εχω το εξης προβλημα:

στο δικο μου pc εχω και linux suse 10.1.

το pc αυτο συνδεεται στο ιντερνετ μεσω του laptop και αυτα τα δυο μεταξυ τους με cat5 καλωδιο και το laptop με το ADSL modem μεσω usb.

εχω πολυ μικρη εμπειρια απο linux και δυσκολευομαι πολυ να το βαλω κι αυτο στο δικτυο. ενα εικονιδιο κατω μου λεει οτι connection established - you are now connected to the wired network.τα αλλα partition του pc (windows xp - vista 32bit - vista 64bit) συνδεονται κανονικα.

εβαλα και ip και dns server αλλα προφανως κανω κατι λαθος...

το laptop (windows xp) εχει:

α. Συνδεση στο Ιντερνετ:

ip address: 192.168.2.137

subnet:255.255.255.0

default gw:192.168.2.1

dns server:194.219.227.2

β. Για τη συνδεση με το δικο μου (που δουλευει με τα αλλα partition windows)

ip:192.168.0.1

subnet:255.255.255.0

dns:192.168.0.1

τα partition των windows δουλευουν με

ip:192.168.0.3 (εως 5)

subnet:255.255.255.0

default gw:192.168.0.1

δεν ξερω τι πρεπει να κανω για να συνδεσω τα suse μεσω του laptop στο ιντερνετ αλλα και να συνδεονται και μεταξυ τους...

θυμιζω οτι εχω πολυ μικρη εμπειρια στα linux

ευχαριστω!!!

ΥΓ:μη μου πειτε να μην κουραζομαι με τα linux αφου θα γυρισω γρηγορα στα windows γιατι εγω τα linux θελω...

Link to comment
Share on other sites

Στο linux έχεις βάλει καρφωτά ip/mask/gw/dns ή παίρνει από dhcp;

Τι έχεις βάλει/ έχει πάρει;

Χτύπα ένα ifconfig ως root να δούμε τι γίνεται.

Link to comment
Share on other sites

τα εβαλα. αλλά δεν ειμαι και πολυ σιγουρος οτι τα εβαλα σωστα. εκανα πολλα. απο τις συσκευες δικτυου και επεξεργασια της καρτας δικτυου ετσι...;:confused:

Link to comment
Share on other sites

Δεν ξέρω αν εγώ φταίω, αλλά δυσκολεύομαι πολύ να καταλάβω το setup σου όπως το περιγράφεις. Έχω όμως να σου δώσω μια συμβουλή: Πέτα το usb modem, δώσε 40 να πάρεις ένα royter/modem της προκοπής και συνέδεσε όλα τα μηχανήματά σου πάνω του. Θεωρώ ότι αυτή είναι η πιο απλή και κομψή λύση.

Link to comment
Share on other sites

εχεις δικιο για το router αλλα αυτη η κατασταση θα ειναι για κανα μηνα και οχι παραπανω και θελω κατι προχειρο. το σπαστικο ειναι οτι γινεται αλλα δεν ξερω πώς...

ολα τα OS απο το desktop 2 βλεπουν κανονικα το laptop και συνδεονται στο ιντερνετ εκτος απο το suse.

και το ifconfig

Link encap:Ethernet HWaddr 00:17:31:90:8F:A8

inet addr:192.168.0.9 Bcast:255.255.255.255 Mask:255.255.255.0

inet6 addr: fe80::217:31ff:fe90:8fa8/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:2 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:494 (494.0 B) TX bytes:0 (0.0 B)

Interrupt:233 Base address:0xc000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:173 errors:0 dropped:0 overruns:0 frame:0

TX packets:173 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:12115 (11.8 Kb) TX bytes:12115 (11.8 Kb)

post-1260-1416073145,2388_thumb.jpg

Link to comment
Share on other sites

Έχεις λάθος broadcast στο eth0, έπρεπε να είναι 192.168.0.255.

Δώσε την παρακάτω εντολή μπας και στρώσει αλλιώς δώσε route -n και τύπωσε την εδώ να δούμε αν διορθώθηκε.

ifconfig eth0 192.168.0.9 broadcast 192.168.0.255 netmask 255.255.255.0

Link to comment
Share on other sites

Μία πιο απλή λύση είναι να δώσεις 15-18 και να πάρεις το πιο φτηνό 100άρι switch που θα βρεις στον skroutz, ρίξε τα πάνω στην ethernet του modem και παίξε από εκεί όλες τις συσκευές στο ίδιο subnet.

Link to comment
Share on other sites

το εκανα αλλα τιποτα. το route -n με προβληματισε

route -n

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

γιατι το gateway ειναι ο.ο.ο.ο.;

πηγα στις ρυθμισεις της καρτας δικτυου και στη δρομολογηση εβαλα 192.168.0.1...;

Link to comment
Share on other sites

Το gateway σωστά είναι 0.0.0.0 γιατί το pc είναι directly connected με το 192.168.0.0/255.255.255.0

Δεν έχεις default gateway όμως, αν δεν το έβαλε με την προσθήκη που λες ότι έκανες το βάζεις με την route add default gw 192.168.0.1

Link to comment
Share on other sites

destination gateway genmask flags iface

192.168.0.0 0.0.0.0 255.255.255.0 U eth0

0.0.0.0 192.168.0.1 0.0.0.0 UG eth0

route -e

destination gateway genmask flags iface

192.168.0.0 * 255.255.255.0 U eth0

default MSHOME 0.0.0.0 UG eth0

Link to comment
Share on other sites

ναι αλλα παλι δε συνδεεται...

σε κουρασα ε;

αν εδινα σε αυτο το default mshome, mask 255.255.255.0 αντι για 0.0.0.0 που εχει λες να γινοταν κατι;

σ ευχαριστω για τον κοπο σου...

Link to comment
Share on other sites

Αρχική απάντηση από achilleas

ναι αλλα παλι δε συνδεεται...

σε κουρασα ε;

αν εδινα σε αυτο το default mshome, mask 255.255.255.0 αντι για 0.0.0.0 που εχει λες να γινοταν κατι;

σ ευχαριστω για τον κοπο σου...

Τότε δε θα έπαιζε σίγουρα.

Κάνε ένα ping στο laptop και στο modem και γράψε εδώ το output.

Link to comment
Share on other sites

linux-ocsc:~ # ping 192.168.0.1

PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

From 192.168.0.9: icmp_seq=2 Destination Host Unreachable

From 192.168.0.9 icmp_seq=2 Destination Host Unreachable

From 192.168.0.9 icmp_seq=3 Destination Host Unreachable

From 192.168.0.9 icmp_seq=4 Destination Host Unreachable

From 192.168.0.9 icmp_seq=6 Destination Host Unreachable

From 192.168.0.9 icmp_seq=7 Destination Host Unreachable

From 192.168.0.9 icmp_seq=8 Destination Host Unreachable

--- 192.168.0.1 ping statistics ---

8 packets transmitted, 0 received, +7 errors, 100% packet loss, time 7000ms

, pipe 3

linux-ocsc:~ # ping 192.168.2.1

PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.

From 192.168.0.9: icmp_seq=1 Destination Host Unreachable

From 192.168.0.9 icmp_seq=1 Destination Host Unreachable

From 192.168.0.9 icmp_seq=2 Destination Host Unreachable

From 192.168.0.9 icmp_seq=3 Destination Host Unreachable

From 192.168.0.9 icmp_seq=4 Destination Host Unreachable

From 192.168.0.9 icmp_seq=5 Destination Host Unreachable

From 192.168.0.9 icmp_seq=6 Destination Host Unreachable

--- 192.168.2.1 ping statistics ---

8 packets transmitted, 0 received, +7 errors, 100% packet loss, time 7026ms

, pipe 3

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.