Jump to content

Καινουριος NVME χαμηλό read κανονικό write


Recommended Posts

Γεια σας. Αλλαξα τον δισκο NVME του λαπτοπ σε HP ex950 1TB. κλωνοποίησα το λειτουργικό χωρίς φορμάτ, ίσως κάνω το καλοκαίρι. ετρεξα ενα τεστ και μου βγάζει κάπου 1600ΜΒ/s κάτω τo read από τις επιδοσεις που δινει ο κατασκευαστής. Το write λίγο κάτω αλλά παραδόξως μεγαλύτερο από το read. Η μητρική είναι Intel HM370 drivers oλα ενταξει, το uefi ρυθμισμένο σε ACHI.  Είναι φυσιολογικές οι επιδόσεις; είναι κάποια ρύθμιση ή driver πχ του nvme που δεν ΄'εχω υπόψη. Ευχαριστώ.

hp ex950 1tb.jpg

Edited by Dorian
Link to post
Share on other sites
  • Dorian changed the title to Καινουριος NVME χαμηλό read κανονικό write

 spacer.png

1797891385_hpex9501tb.jpg.81b1f714617124afb7d73d22e8a6dbb3.jpg 1TB. 

Eίναι ο ΗP ex950 1Tb. Δεν απασχολεί κάτι άλλο το δίσκο και CPU από επιδόσεις στην διαχείριση εργασιών είναι στο 0-1-2% η χρήση. στο τέστ πιάνει 100% ο δισκος. Χρειάζεται κάποιο software/driver για τις εκδόσεις NVME; αυτός λεει ειναι NVME 1.3 . Το SMART λέει 100% health. ΠΡαγματικά δεν μπορώ να σκεφτώ γιατί δεν παει καλύτερα.

Link to post
Share on other sites

To AHCI έχει να κάνει με sata drives. Λογικά θα έχεις και δεύτερη sata θύρα και μάλλον εκεί απευθύνεται. Δοκίμασε να εγκαταστήσεις RST drivers ή τσέκαρε αν είναι εγκατεστημένοι. Νομίζω για το 370 οι τελευταίοι είναι 17.9.1.1009.

Στα setting του diskmark βάλε nvme.

  • Like 2
Link to post
Share on other sites

Είναι PCIe 3.0 x4 η υποδοχή του laptop?

 

Ένα γρήγορο τεστ για να δούμε αν είναι κάποιο θέμα των windows είναι να μπουτάρεις με ένα live linux mint 20 από usb και να τρέξεις μέσω του DISK tool ένα γρήγορο benchmark για να δούμε τι ψάρια πιάνει και εκεί.

  • Like 1
Link to post
Share on other sites
14 hours ago, suboy said:

To AHCI έχει να κάνει με sata drives. Λογικά θα έχεις και δεύτερη sata θύρα και μάλλον εκεί απευθύνεται. Δοκίμασε να εγκαταστήσεις RST drivers ή τσέκαρε αν είναι εγκατεστημένοι. Νομίζω για το 370 οι τελευταίοι είναι 17.9.1.1009.

Στα setting του diskmark βάλε nvme.

οντως εχει δευτερο κανονικό σκληρό. Δεν ήταν εγκατεστημένο το rst. μπερδεύτηκα γιατί κοίταξα στις συσκευές και είδα τους sata/achi controller εγκατεστημενο. Το 18 rst δεν υποστηρίζεται. Το 17 εκανε επανεκκίνιση σε safe mode αλλά δε εγκαθιστά τίποτα ούτε το σημαντικότερο drivers για ελεγκτές NVME. ΄τωρα έχει ένα default του 2006 της Microsoft. Παλαιότεροι rst εγκαθίστανται αλλά δεν βάζουν drivers για NVME. 

 

Link to post
Share on other sites

ποιο laptop έχεις? Στο δικό μου με H370 είναι εγκατεστημένοι οι 17.9.1.1009

Μόνο η samsung έχει drivers για NVMe. Λογικά θα πρέπει να δεις τους rst στο "storage controllers"

Link to post
Share on other sites

Επιμένω να τεστάρεις τον nvme εκτός windows. Είναι 5 λεπτά υπόθεση. Μετά μπορείς να είσαι σίγουρος αν είναι θέμα windows ή hardware. Μπορεί να είναι άλλη μια περίπτωση nvme που η εταιρεία αλλάζει controller ή nand flash και οι επιδόσεις είναι άλλες από τις διαφημιζόμενες. 

Link to post
Share on other sites
8 hours ago, suboy said:

ποιο laptop έχεις? Στο δικό μου με H370 είναι εγκατεστημένοι οι 17.9.1.1009

Μόνο η samsung έχει drivers για NVMe. Λογικά θα πρέπει να δεις τους rst στο "storage controllers"

Lenovo Legion Y540-15IRH-PG0, i5 9300h HM370 Μητρική, 1650. είχε ένα noname 128gb NVMe 1,χρόνο και κατι ούτε που τον είχα τεστάρει. Νομίζω βρήκα το θέμα, στις ρυθμίσεις UEFI storage options έχει ACHI mode και RST mode. οταν πάω να το αλλάξω βγάζει μήνυμα προειδοποίησης ότι θα διαγραφούν τα δεδομένα όλων των δίσκων. Οπότε για αυτό δεν εγκαθήείσταται ο 17 RST σε premium mode Που λογικά θα παίρνει drivers και για nvme controller. Φορματ δεν παίζει τώρα να κάνω. Εσας σε RST premium βάζει driver και για NVME, κάνει διαφορά στις επιδόσεις; ουσιαστικά είναι ο πρώτος NVME Που έχω. 

8 hours ago, gdp77 said:

Επιμένω να τεστάρεις τον nvme εκτός windows. Είναι 5 λεπτά υπόθεση. Μετά μπορείς να είσαι σίγουρος αν είναι θέμα windows ή hardware. Μπορεί να είναι άλλη μια περίπτωση nvme που η εταιρεία αλλάζει controller ή nand flash και οι επιδόσεις είναι άλλες από τις διαφημιζόμενες. 

Δεν μπορώ για κάποιο ανεξήγητο λόγο να μπουτάρω από usb stick. προσπαθούσα 3 μέρες να τρέξω memtest γιατι πρόσθεσα και άλλο ένα στικάκι 8 γιγα μνήμη δεν το έβλεπε με τίποτα το usb για να μπουτάρει από αυτό . τελικά έβαλα το τεστ των windows μνήμης

Edited by Dorian
  • Like 1
Link to post
Share on other sites

Αν ξέρεις να το χρησιμοποιείς θα μπορούσες να πάρεις ενα image με boot-cd acronis και να δοκιμάσεις να το αλλάξεις.

screenshot από το δικό μου (HP omen). Από clean installation πάντα με rst ήμουν. To 1.9GB/s στο read δεν γνωρίζω κατά πόσο είναι οκ. Το 2.4 στο write δείχνει οκ. Δοκίμασε αν θες και αυτό που λέει ο gdp77 με το linux live.   τώρα το είδα.

 

@jax7480 Αν βλέπεις ότι έχουμε κάνει πατάτα κάπου θα ήταν χρήσιμη η βοήθειά σου. thanx.

 

image.thumb.png.a289d4fc189fe33c49d93eedf3d2ce7e.png

Edited by suboy
  • Like 1
Link to post
Share on other sites

Παντως και σε dell και σε lenovo μου εχει τυχει να παιζει σε 2x για να κραταει περισσοτερο μπαταρια...και δυστυχώς αλλαζει μονο με πειραγμενο bios...

 

το hwinfo τι link βγαζει?

 

Edited by GeorgeVasil
  • Like 1
Link to post
Share on other sites
On 12/28/2020 at 9:07 PM, jax7480 said:

Το performance mode των windows σε τι ρυθμιση ειναι; αν δεν ειναι High Performance αλλαξε το και δοκιμασε παλι.

To ίδιο βγάζει. 

On 12/28/2020 at 10:10 PM, GeorgeVasil said:

Παντως και σε dell και σε lenovo μου εχει τυχει να παιζει σε 2x για να κραταει περισσοτερο μπαταρια...και δυστυχώς αλλαζει μονο με πειραγμενο bios...

 

το hwinfo τι link βγαζει?

 

4Χ και τρέχει σε 4χnvme4x.thumb.jpg.86c681ca00b9fb5ad5868d77dee260df.jpg

Σε live linux καλύτερες επιδόσεις αλλά πάλι κάτω από το write1609279573093.thumb.jpg.f2747c6c45286a222910efef11ca52be.jpg

Δεν ξέρω τι άλλο κάποια στιγμή θα δοκιμάσω και φορματ με rst στο uefi και βλέπουμε αν και μάλλον μου κατσε πατάτα.

Link to post
Share on other sites
13 hours ago, Dorian said:

Δεν ξέρω τι άλλο κάποια στιγμή θα δοκιμάσω και φορματ με rst στο uefi και βλέπουμε αν και μάλλον μου κατσε πατάτα.

 

Δεν ξέρω αν γράφω βλακείες τώρα, αλλά νομίζω ότι το RST mode αφορά σε RAID. Κανονικά ο δίσκος θα έπρεπε να σου δώσει τις διαφημιζόμενες ταχύτητες σε AHCI mode. Εγώ "ποντάρω τα χρήματά μου" στην πιθανότητα να μην παίζει σε πραγματικό PCIe x4 ο nvme σου, λόγω περιορισμού στο hardware του laptop. Εντάξει το Linux είναι γενικά καλύτερο σε τέτοια θέματα, αλλά βλέπω έχεις και αρκετή διαφορά από τα Windows στα sequential read/writes. Πιο ψαγμένοι με nvme, ας τοποθετηθούν @jax7480

 

YΓ Μπορείς και στο linux live να πάρεις screenshot 😛

 

 

Edited by gdp77
  • Like 1
Link to post
Share on other sites
10 hours ago, suboy said:

Πριν κάνεις οτιδήποτε δες εδώ. Το είδα στα γρήγορα δεν ξέρω αν όντως ισχύει ή αν έχει άλλο fw ο 1TB.

 

 

 

Eχει τις μετρήσεις εδώ σχεδόν ίδιες  με τις δικές μου στο before. οπότε είναι θέμα firmware, για 1ΤΒ δεν υπάρχει πουθενά τίποτα, ούτε το παραμικρό στην ΗP. Μου έκατσε σαβουροδίσκος, σε 4-5 review κανείς δεν είπε τίποτα.

spacer.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.